zen-cart网站,模版,采集,二次开发

首页 » ZenCart » ZenCart教程 » 阅读文章

ZenCart批量上传插件Easy Populate最新版错误修正方案

2014-02-02 00:36 18213 1 发表评论
标签:


Easy Populate是zencart用的最广泛的批量上传插件.且最新版支持zencart1.5.1版本,但是可能是作者的疏忽还是留下的几个小bug.

下载

错误一: 1.39版语言项被覆盖缺失

原因: 由于1.39 与1.50 1.50中YOUR_ADMIN\includes\languages\english.php有所不同,但是插件直接使用1.5.x的english.php导致1.39版语言有所缺失

解决方案: 删除YOUR_ADMIN\includes\languages\english.php,将Easy Populate中需要用到的语言项转移到YOUR_ADMIN\includes\languages\english\extra_definitions\easypopulate.php中

Easy Populate中需要用到的语言项转移到YOUR_ADMIN\includes\languages\english\extra_definitions\easypopulate.php中添加

define('BOX_CONFIGURATION_EASY_POPULATE', 'Easy Populate');

错误二: 1.5.x版Configuration中Easy Populate配置项没有显示

解决方案:

YOUR_ADMIN\includes\functions\extra_functions\easypopulate_functions.php查找

function install_easypopulate() {

函数末尾增加

	if (function_exists('zen_register_admin_page')) {
			if (!zen_page_key_exists('easyPopulateConfig')) {
						 zen_register_admin_page('easyPopulateConfig', 'BOX_CONFIGURATION_EASY_POPULATE',
									 'FILENAME_CONFIGURATION','gID='.$group_id , 'configuration', 'Y', 300);
			}
	}

错误三: 部分空间Tools-->Easy Populate部分乱码错误问题

原因: 这是因为部分空间未开启短标签,而tempEP文件夹的中的2个php文件全部使用的短标签,导致引入的php未被解析,而是直接输出

解决方案:,将短标签补全(ps:如果你想省事,你可以开启空间的php短标签功能,然后重启apahce即可)

修正版下载

随机日志

评论 共1条 (RSS 2.0) 发表评论

  1. wsrf 说道:

    最新1.54,安装最新版本的会出错这个要怎么解决

发表评论

  • 
  • 插入代码

联系我 Contact Me

回到页首